Welcome to LG webOS - Smart TV, Phone, Signage, Appliance User to User Support Forum

Register now to gain access to our webOS user support forum. Once registered and logged in, you will be able to post a user to user support request topic to this site or reply to existing topics posted by other users. You can also take part in our other webOS user forums. You'll be able to customize your profile, receive reputation points, while also communicating with other members via your own private inbox, plus much more!

This message will be removed once you have signed in.

G.A.

Smartshare audio track change problem

21 posts in this topic

How to change audio language?

I Was watching a film. (Mkv)

I stopped playback.

Tv said there is firmware update. I updated to firmware 04.30.09.

Later i wanted to continue the film, but the audio language changed to english. I can not switch It back to to original. The audio icon in the menu is inactive (like It was always).

Im playing the film through Dlna from my NAS.

Any ideas, how to Change language?

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

I have the same problem after update.

I can't switch language from english when playing mkv over DLNA from my PC HDD.

It can be fixed if I delete all audio except required languge from mkv file.

I think that is new firmware bug.

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

I have the same issue. The local support told me unfortunately the DLNA client does not support switching audio streams. However, watching the same MKV from USB works fine, I can switch between audio streams.

 

Hopefully they'll solve this problem in the DLNA client because I don't want to remove additional audio streams from each and every MKV I have.

1 person likes this

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

I have the same issue. The local support told me unfortunately the DLNA client does not support switching audio streams. However, watching the same MKV from USB works fine, I can switch between audio streams.

 

Hopefully they'll solve this problem in the DLNA client because I don't want to remove additional audio streams from each and every MKV I have.

Ok, no changing Tracks on DLNA, but I checked the MKV file with MKVMerge.

My wanted audio track was the first, it had the same language whitch is set default on TV, and it was the default audio Track in MKV.

So it seems WebOS picks audio track randomly. (or it always picks the English Track...)

I hope it will change soon.

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

Ok, no changing Tracks on DLNA, but I checked the MKV file with MKVMerge.

My wanted audio track was the first, it had the same language whitch is set default on TV, and it was the default audio Track in MKV.

So it seems WebOS picks audio track randomly. (or it always picks the English Track...)

I hope it will change soon.

 

It's closer to random. Mostly it chooses English but there are cases when other streams come out as winners. FYI, I've created a shell script to easily create a copy of an MKV file with the video and one audio stream. It's on GitHub: https://gist.github.com/csiknor/ad9d9db0f0f2cb9767a6

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.


Local languge came back as default with new firmware update for mkv in DLNA client. Howewer audio languges switch does not work.

So only one local audio track from mkv file is avalable to play.

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

Local languge came back as default with new firmware update for mkv in DLNA client. Howewer audio languges switch does not work.

So only one local audio track from mkv file is avalable to play.

 

I have updated to the latest firmware but the issue is still there. I have an MKV with multiple audio tracks and the playback starts with the english one not the local language (the language settings are set to define hungarian as the local language).

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

smartshare app always pick english commentary audio track, stupidshare. i must remove other tracks from mkv to play audio i need. my firmware 04.30.xx , LG should test their apps.

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

I have local language plaing with my mkv files now. Not sure how DLNA client select tracks to play but each mkv file has adio "track#" and "default" property for each audio track.

My files have local languge as track #1 and its "default " property = yes.

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

i cant activate any subtitles as well (over DLNA streaming files)... anyone with the same problem?
media played over USB devices works fine with subs and audio options

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.


I have the same problem too. I have updated to the latest firmware for Vietnamese (4.30.16) but the issue is still there :(
Fix it please!

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

Can not change language track. Please introduce this feature. I have latest LG WebOS version.

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

The same problem here on LG 42LB670V with the latest WebOS. Please fix it!

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

Hi! I started having this annoying issue on my 42" 42LA740S after an update, probably the same as you. Out of the box it was possibile to switch language and subtitles while streaming (I use Plex as media server on my PC). I'm trying to get an answer from the LG italian support, but I expect nothing  :unsure:

 

I think they removed this functionality from the DLNA player for some reason, and they are never putting it back  :huh: 

Maybe if we flood the support with emails.... :D

edit: I found this article explaining how to downgrade TV firmware 

http://blog.techflaws.org/2014/05/26/firmware-downgrade-for-lg-smart-tvs/

 

I'm not new to this kind of thing, but I think is a little dangerous because there is no "recovery mode" or a way to flash the firmware directly from a pendrive USB, but you need to trick the TV to make it download a specific version of the software from your PC instead of LG official website.

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

Actually, with the latest software update the whole issue has has been resolved for me. I'm able to select audio track and subtitles provided in the MKV files.  :)

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.


 

Actually, with the latest software update the whole issue has has been resolved for me. I'm able to select audio track and subtitles provided in the MKV files.  :)

 

Are you sure it works streaming from a DLNA server like Plex? I just received last update (04.27.05) but this ain't changed. What is your software version?

 

I attach a detailed screenshot of my sw version  :)

post-5215-0-88151800-1443873758_thumb.jpg

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

Are you sure it works streaming from a DLNA server like Plex? I just received last update (04.27.05) but this ain't changed. What is your software version?

 

I attach a detailed screenshot of my sw version  :)

Yes, I'm using my NAS as the DLNA server. It used to be the case that I was unable to change audio tracks, although the TV could handle multiple audio tracks when I used the same file via USB instead of DLNA.

 

Please hav my software version as following:

https://dl.dropboxusercontent.com/u/430331/LG%20webOS%20DLNA/IMG_3633.jpg

https://dl.dropboxusercontent.com/u/430331/LG%20webOS%20DLNA/IMG_3634.jpg

 

This is an LG 42LB671V.

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

Yes, I'm using my NAS as the DLNA server. It used to be the case that I was unable to change audio tracks, although the TV could handle multiple audio tracks when I used the same file via USB instead of DLNA.

 

Please hav my software version as following:

https://dl.dropboxusercontent.com/u/430331/LG%20webOS%20DLNA/IMG_3633.jpg

https://dl.dropboxusercontent.com/u/430331/LG%20webOS%20DLNA/IMG_3634.jpg

 

This is an LG 42LB671V.

oh, your software version is 5 ... I don't know if my TV will get it...I hope so!

 

Thank you!

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

It's not immediately obvious but you CAN change the subtitles and audio track on Web OS 4.0.0.0. Here is how:

 

1) In Smartshare, choose a video and play it.

2) When Playing a video, click on the Additional Options icon. It's a left arrow Icon (<--) at the bottom right of the player.

3) Once you click the left arrow, it's clear. You can select the Subtitle option or Audio options. If the icons are disabled, it means it the video doesn't have addiitonal subtitles/audio.

 

That's it. I hope that helps.

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

Audio language selection become available about 2 months ago with firmware update. I have TV model of 2014 year.

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.


Hello everyone. I am having the same issue as everyone. Change language track is disabled in the menu. I am pretty sure I was able to do that a couple of months ago. Probably I updated the firmware. The TV is a LG 32LB580B-SA-SA_37. Firmware is 04.02.06 and Tv says there is no update available

Share this post


Link to post
Share on other sites
  •  Like what you are reading? Please help us by sharing this content.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  •  Like what you are reading? Please help us by sharing this content.
  • Similar Content

    • By fynotfi
      When will the Spotify app be available for webOS?
    • By LG dazn watcher
      Hi, 
      i am a big sports fan and have a dazn account. Now it is a shame that i can't watch on my smart tv from LG! Model name:
      49LJ614V-ZA see screenshot for firmware etc
      will this app ever be available or do i have to get another tv?
      thanks a lot in advance!
      best regards

    • By Zoltan Szabo
      Hello
      I own an OLED55C6 with latest updates, but I have a problem with the Photo & Video app. After stopping and restarting a movie, the previously selected language and subtitle settings are gone, and I have to select them again. Would be great if my language and subtitle choices would be persistent for each video, so if I re-watch the same movie after a while, it knows what language/subtitle I selected already. 
      Another  request would be to have the possibility to have the videos listed only with their names, without thumbnails.
      If I would have these 2 things, I could retire my raspberry pi
    • By Wigo
      My LG 55" UJ630v , WebOS version: 03.60.15
      When using Home Audio system, and streaming TV sound to audio system via bluetooth, there is always sound lag (lip sync delay)... 
      i failed to find any setting for sound/audio speed to be able synchronize audio with TV.
       
      Please advise.