Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    Register now to gain access to our webOS user support forum. Once registered and logged in, you will be able to post a user to user support request topic to this site or reply to existing topics posted by other users. You can also take part in our other webOS user forums. You'll be able to customize your profile, receive reputation points, while also communicating with other members via your own private inbox, plus much more!

bogeyman62

Screen Share with Windows 10

Recommended Posts



Finally! I could connect after 5 months of trying every now and then.. you can see the log of my attempts in this thread ;) Hence the first thing I am doing on connecting successfully is to write about it here :)
Two things helped made it work -

Step 1: Update Windows 10 to the latest version - version 1803, build 17134.48
If you have not received this update yet (in my case, it was downloaded automatically but failed to instal several times) go to the Windows update center online, download and install the update manually.
This alone did not suffice for me, what happened was that the LG TV would get connected for a few seconds and then get disconnected again.

Step 2: So, what worked for me is that I happened to disconnect the TV from the internet connection but leave the WiFi radio 'ON' in the TV.  Your laptop could stay connected to the internet, does not matter but the TV shouldn't (perhaps it can handle a connection to just one device at a time!!). Go to Screen share on the TV and try connecting from the 'Connect' option in the Windows 10  notification menu of the taskbar and that should be it!

Share this post


Link to post
Share on other sites

I've been having the same problem that everyone else has been discussing and tried all of the various solutions here to no avail.

I eventually solved the problem by adjusting the settings on my AVG firewall. This may sound very obvious but I never considered it until seeing references in other posts about firewall interference. Since it has not been mentioned here, I thought I would let people know in case their connection problem is also a firewall problem.

Hopefully, this will help others.

  • Like 1

Share this post


Link to post
Share on other sites


38 minutes ago, AlanFP said:

I've been having the same problem that everyone else has been discussing and tried all of the various solutions here to no avail.

I eventually solved the problem by adjusting the settings on my AVG firewall. This may sound very obvious but I never considered it until seeing references in other posts about firewall interference. Since it has not been mentioned here, I thought I would let people know in case their connection problem is also a firewall problem.

Hopefully, this will help others.

Can you let us know what setting you altered please?

Share this post


Link to post
Share on other sites

Last weekend, an MS update for Win 10 popped up on both of my machines at home. Turned out to be a major update - build 1083 if I recall.  Got me to wondering if it would have any positive affect on the office Dell Lattitude I've been having the Wi-di issue with. I ran the upgrade on the Lattitude then the Dell Support and Assist window popped up announcing driver and hardware updates - one was related to graphics - so I ran all three of those. And, like magic, Wi-di is now working flawlessly on the Lattitude. I keep going into our conference room daily to check it and it connects without issue every time. It connects to either the LG itself or the MS Wireless Display adapter connected to it - either works just fine now.

*Update: 5-27-18 - apologies to Snapdrag - did not see your post above until now. I usually get notifications of new posts.

Edited by Foodie
Info Update

Share this post


Link to post
Share on other sites
2 hours ago, George Hofmeister said:

Can you let us know what setting you altered please?

I followed some instructions I found on the AVG support site:

Change AVG Firewall network profile to private (open AVG Internet Security > menu > settings > components > firewall > customize > network profile > change all the networks from public to private)  then go to Firewall customize settings again > scroll down > click on system rules > enable all the system rules if they're not configured then click OK.

May sound a bit garbled but is quite easy to follow and solved my problem.

Good luck!

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, AlanFP said:

I followed some instructions I found on the AVG support site:

Change AVG Firewall network profile to private (open AVG Internet Security > menu > settings > components > firewall > customize > network profile > change all the networks from public to private)  then go to Firewall customize settings again > scroll down > click on system rules > enable all the system rules if they're not configured then click OK.

May sound a bit garbled but is quite easy to follow and solved my problem.

Good luck!

Thanks for the info Alan, it may help others with similar issues.

Share this post


Link to post
Share on other sites
On 1/12/2017 at 8:55 AM, turubara said:

It's quite easy. First, just run Screen Share on your TV (find it in LG TV content), then connect wireless display on your PC (push buttons windows+P - it must start automatically).

brilliantly simple

Share this post


Link to post
Share on other sites


In my situation, running a 30 ft. HDMI cable across the conference room is not an option and wouldn't be practical.  We need the ability to meet with a client in one of three different conference rooms and have the ability to project from the laptop to the wall mounted TV/display. Today's modern office  shouldn't and doesn't require cables strewn about the place.

Share this post


Link to post
Share on other sites

Also if I may add:

Be sure to disable Auto Rotate if your using a Surface Pro.  I walk around my classroom and write notes and solve math problems.  If I set the Surface down or hold it wrong it will want to rotate the screen.  If this happens the TV gets squirrelly and you may have to reconnect.  

Also as a side note I've been able to play videos pretty well across the screen share.  

Hope this helps.

Share this post


Link to post
Share on other sites
On 5/25/2018 at 4:59 PM, Foodie said:

Last weekend, an MS update for Win 10 popped up on both of my machines at home. Turned out to be a major update - build 1083 if I recall.  Got me to wondering if it would have any positive affect on the office Dell Lattitude I've been having the Wi-di issue with. I ran the upgrade on the Lattitude then the Dell Support and Assist window popped up announcing driver and hardware updates - one was related to graphics - so I ran all three of those. And, like magic, Wi-di is now working flawlessly on the Lattitude. I keep going into our conference room daily to check it and it connects without issue every time. It connects to either the LG itself or the MS Wireless Display adapter connected to it - either works just fine now.

*Update: 5-27-18 - apologies to Snapdrag - did not see your post above until now. I usually get notifications of new posts.

It is fine Foodie! No worries :) But my laptop always hangs the first time that I connect it with the TV. Once I restart (actually reset the laptop) it is fine. This repeats each time I try to connect. Do you have the same problem as well?

Share this post


Link to post
Share on other sites

Snapdrag:

I do not have that issue.  However, I cannot walk into our conference room with laptop in hand and powered on and connect to the LG Smart TV. The laptop doesn't "see" the TV.  I ALWAYS have to re-boot the laptop and let it discover the TV.

Share this post


Link to post
Share on other sites


Oh! seems like a similar problem, just that my laptop thinks it can do nothing if it cannot connect to the TV!
Let's see if the others have faced a similar problem and have a solution.

Share this post


Link to post
Share on other sites

Just thought I would post my experience and solution here and hope it helps some:

My quick solution (so you don't have to read all the details): Disconnect TV and PC from wifi router and let the two connect directly. Screen Share uses Miracast and it is a direct wifi connection (no router needed).

Now the long story: I was having similar issues where I couldn't connect to my new LG TV (WebOS 3.5) with Screen Sharing and an all updated Dell Windows 10 laptop. Well actually I could, it would work about 5% of the time...that's 5% not 50% so it was very frustrating and most of the time on the failures the laptop would lockup and I would have to hold the power button down to shut the machine off. After reading some of the solutions here and reading some other threads elsewhere the thing that made a light bulb go on was when I read that Miracast is a DIRECT wifi connection between both devices...No Router Needed. So like some have suggested, I disconnected my TV from the wifi router and disconnected my laptop from the wifi router and let the two devices conduct their hand shakes and whatnots directly without a network router middle man. IT WORKED!!! Once the screen sharing worked I connected both devices back to the wifi network router and all worked great (except the LG TV did not remember the wifi password and I had to re-enter it). 

Side note: I am one of the few people left in the world with a Windows 10 phone and the Continuum app on it connected 100% of the time regardless if either was connected to my wifi router or not. haha I love my windows phone, lack of apps or not it does what I need it to do...hope they follow through on the Surface phone or "Andromeda" phone or whatever it will be called.

Hope this helps some out there.

Edited by maestro0369
Error in what I wrote

Share this post


Link to post
Share on other sites

I want to mirror my notebook's screen into my LG TV, but I can do it only if TV is disconnected from internet. If I connect to wifi, the TV disappears from projection devices on Windows and appear only when I turn off TV's wifi connection. I've already updated my notebook drivers, made a clean install of Windows 10, review windows and router settings but I can't find what is doing this issue. My Android (LG G6) can mirror normally with TV connected or not to the wifi.

 

In my work, all of the notebooks running W10 (three lenovo, one samsung and one asus) can project to LG TVs (three of them but two different models) connected to the internet or not.

 

I'am trying to find out what it's going on here but I'm only wasting time for now.
 

Share this post


Link to post
Share on other sites
On 6/30/2018 at 11:21 PM, maestro0369 said:

Just thought I would post my experience and solution here and hope it helps some:

My quick solution (so you don't have to read all the details): Disconnect TV and PC from wifi router and let the two connect directly. Screen Share uses Miracast and it is a direct wifi connection (no router needed).

Now the long story: I was having similar issues where I couldn't connect to my new LG TV (WebOS 3.5) with Screen Sharing and an all updated Dell Windows 10 laptop. Well actually I could, it would work about 5% of the time...that's 5% not 50% so it was very frustrating and most of the time on the failures the laptop would lockup and I would have to hold the power button down to shut the machine off. After reading some of the solutions here and reading some other threads elsewhere the thing that made a light bulb go on was when I read that Miracast is a DIRECT wifi connection between both devices...No Router Needed. So like some have suggested, I disconnected my TV from the wifi router and put my laptop into airplane mode (it turns off the wifi or you could just turn off wifi) and let the two devices conduct their hand shakes and whatnots directly without a network router middle man. IT WORKED!!! Once the screen sharing worked I connected both devices back to the wifi network router and all worked great (except the LG TV did not remember the wifi password and I had to re-enter it). 

Side note: I am one of the few people left in the world with a Windows 10 phone and the Continuum app on it connected 100% of the time regardless if either was connected to my wifi router or not. haha I love my windows phone, lack of apps or not it does what I need it to do...hope they follow through on the Surface phone or "Andromeda" phone or whatever it will be called.

Hope this helps some out there.

I tried this and it doesn't work for me. By the way, you cannot share your screen on airplane mode. You have to have the wi-fi on. Doesn't have to be connected to the internet but the wi-fi radio must be turned on.

An update from my last post - I get over the issue of the laptop hanging up its boots each time I connect to the TV by restarting the laptop before each time I connect it. This makes it work seamlessly. It is disheartening to see how all of us have been struggling for so long with this issue, wasting so much time and neither Microsoft or LG care to do anything about it!

Share this post


Link to post
Share on other sites
On 7/2/2018 at 12:19 PM, Snapdrag said:

By the way, you cannot share your screen on airplane mode. You have to have the wi-fi on. 

Yes, you are correct and I was just going to make a note of the very same thing here.  Sorry for any confusion I it may have caused.

Share this post


Link to post
Share on other sites


Another update: Now it lets me connect with the TV still connected to the wifi router but the laptop has to disconnected from the wifi router...this really is a head scratcher and I agree Microsoft or LG or both need to figure out what the issue is because this is completely unacceptable that so many people are struggling with this.

Share this post


Link to post
Share on other sites

FWIW, I have a WIN10 64bit laptop, Lenovo Y40, with the latest WIN10 SW/Updates, (Windows 10 Home (x64) Version 1803 (build 17692.1004), & my LG TV is:  

Model      OLED65B7A-U

S/N          709RMJF8xxxx

SW Version 04.71.00

webOS Version 3.7.1.57127

(dreadlocks2-drto)

Dolby Vision 1.4.4_07.01

I am able to screen share my PC with the PC connected to my RG using 2.4gHz and the LG TV connected to the same RG using 5gHz.  I use the WIN + P keys on the PC after starting  Miracast on the LG TV.  Hope this helps.  Note RG is AT&T U-Verse remote gateway with the builtin WI-FI router. 

I also have a Chromecast dongle connected which works but I am not using it for this screen share.

My pictures really pop and look great when displayed on the LG TV.

Share this post


Link to post
Share on other sites

hi travis

you can connect easy with own lg oled tv. Open your tv screen share option and open own pc window10 settings. select device connection and select on option widi or wireless device connection. and select your tv model. than now you can see easy to connect your pc with your oled tv.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×