Quantcast

Jump to content

Slate Cloud Plum Berry Lawn Lime Orange Coco

Welcome webOS Fan, Sign Up Free!


Create Account Sign In
This is LG webOS, which stands for "Lets Go webOS", a site dedicated to webOS and its fans. Like most online communities you must register to take part and post in this forum. This is a fast and free process that requires minimal information from you. Be a part of LG webOS by signing in or creating an account. You can also use your Facebook or Twitter account to make it even easier!
 

Photo

Smartshare audio track change problem

Smartshare webos dlna nas

  • Please log in to reply
19 replies to this topic

#1 G.A.

G.A.

    Newbie

  • Members
  • Pip
  • 4 posts

Posted August 30, 2014 - 05:23 PM

How to change audio language?

I Was watching a film. (Mkv)
I stopped playback.
Tv said there is firmware update. I updated to firmware 04.30.09.
Later i wanted to continue the film, but the audio language changed to english. I can not switch It back to to original. The audio icon in the menu is inactive (like It was always).
Im playing the film through Dlna from my NAS.

Any ideas, how to Change language?


#2 Yuriy

Yuriy

    Newbie

  • Members
  • Pip
  • 7 posts

Posted September 01, 2014 - 04:16 PM

I have the same problem after update.

I can't switch language from english when playing mkv over DLNA from my PC HDD.

It can be fixed if I delete all audio except required languge from mkv file.

I think that is new firmware bug.



#3 csiknor

csiknor

    Newbie

  • Members
  • Pip
  • 5 posts

Posted September 02, 2014 - 02:52 PM

I have the same issue. The local support told me unfortunately the DLNA client does not support switching audio streams. However, watching the same MKV from USB works fine, I can switch between audio streams.

 

Hopefully they'll solve this problem in the DLNA client because I don't want to remove additional audio streams from each and every MKV I have.



#4 G.A.

G.A.

    Newbie

  • Members
  • Pip
  • 4 posts

Posted September 05, 2014 - 03:56 PM

I have the same issue. The local support told me unfortunately the DLNA client does not support switching audio streams. However, watching the same MKV from USB works fine, I can switch between audio streams.

 

Hopefully they'll solve this problem in the DLNA client because I don't want to remove additional audio streams from each and every MKV I have.

Ok, no changing Tracks on DLNA, but I checked the MKV file with MKVMerge.

My wanted audio track was the first, it had the same language whitch is set default on TV, and it was the default audio Track in MKV.

So it seems WebOS picks audio track randomly. (or it always picks the English Track...)

I hope it will change soon.



#5 csiknor

csiknor

    Newbie

  • Members
  • Pip
  • 5 posts

Posted September 05, 2014 - 04:16 PM

Ok, no changing Tracks on DLNA, but I checked the MKV file with MKVMerge.

My wanted audio track was the first, it had the same language whitch is set default on TV, and it was the default audio Track in MKV.

So it seems WebOS picks audio track randomly. (or it always picks the English Track...)

I hope it will change soon.

 

It's closer to random. Mostly it chooses English but there are cases when other streams come out as winners. FYI, I've created a shell script to easily create a copy of an MKV file with the video and one audio stream. It's on GitHub: https://gist.github....db0f0f2cb9767a6



#6 Yuriy

Yuriy

    Newbie

  • Members
  • Pip
  • 7 posts

Posted October 05, 2014 - 06:50 AM

Local languge came back as default with new firmware update for mkv in DLNA client. Howewer audio languges switch does not work.

So only one local audio track from mkv file is avalable to play.



#7 csiknor

csiknor

    Newbie

  • Members
  • Pip
  • 5 posts

Posted October 12, 2014 - 08:45 AM

Local languge came back as default with new firmware update for mkv in DLNA client. Howewer audio languges switch does not work.

So only one local audio track from mkv file is avalable to play.

 

I have updated to the latest firmware but the issue is still there. I have an MKV with multiple audio tracks and the playback starts with the english one not the local language (the language settings are set to define hungarian as the local language).



#8 womanizerzz

womanizerzz

    Newbie

  • Members
  • Pip
  • 4 posts

Posted October 22, 2014 - 01:02 PM

smartshare app always pick english commentary audio track, stupidshare. i must remove other tracks from mkv to play audio i need. my firmware 04.30.xx , LG should test their apps.


#9 Yuriy

Yuriy

    Newbie

  • Members
  • Pip
  • 7 posts

Posted October 23, 2014 - 01:16 AM

I have local language plaing with my mkv files now. Not sure how DLNA client select tracks to play but each mkv file has adio "track#" and "default" property for each audio track.

My files have local languge as track #1 and its "default " property = yes.



#10 Gabriel Duran

Gabriel Duran

    Newbie

  • Members
  • Pip
  • 7 posts

Posted March 10, 2015 - 11:32 AM

i cant activate any subtitles as well (over DLNA streaming files)... anyone with the same problem?
media played over USB devices works fine with subs and audio options



#11 hoanganhbmt

hoanganhbmt

    Newbie

  • Members
  • Pip
  • 1 posts

Posted March 18, 2015 - 12:51 AM

I have the same problem too. I have updated to the latest firmware for Vietnamese (4.30.16) but the issue is still there :(
Fix it please!



#12 wormhit

wormhit

    Newbie

  • Members
  • Pip
  • 1 posts

Posted April 15, 2015 - 03:44 PM

Can not change language track. Please introduce this feature. I have latest LG WebOS version.



#13 petoroland

petoroland

    Newbie

  • Members
  • Pip
  • 1 posts

Posted July 03, 2015 - 06:21 AM

The same problem here on LG 42LB670V with the latest WebOS. Please fix it!



#14 benny.evangelista

benny.evangelista

    Newbie

  • Members
  • Pip
  • 3 posts

Posted October 02, 2015 - 04:36 AM

Hi! I started having this annoying issue on my 42" 42LA740S after an update, probably the same as you. Out of the box it was possibile to switch language and subtitles while streaming (I use Plex as media server on my PC). I'm trying to get an answer from the LG italian support, but I expect nothing  :unsure:

 

I think they removed this functionality from the DLNA player for some reason, and they are never putting it back  :huh: 

Maybe if we flood the support with emails.... :D

edit: I found this article explaining how to downgrade TV firmware 

http://blog.techflaw...r-lg-smart-tvs/

 

I'm not new to this kind of thing, but I think is a little dangerous because there is no "recovery mode" or a way to flash the firmware directly from a pendrive USB, but you need to trick the TV to make it download a specific version of the software from your PC instead of LG official website.



#15 csiknor

csiknor

    Newbie

  • Members
  • Pip
  • 5 posts

Posted October 02, 2015 - 01:50 PM

Actually, with the latest software update the whole issue has has been resolved for me. I'm able to select audio track and subtitles provided in the MKV files.  :)



#16 benny.evangelista

benny.evangelista

    Newbie

  • Members
  • Pip
  • 3 posts

Posted October 03, 2015 - 07:03 AM

 

Actually, with the latest software update the whole issue has has been resolved for me. I'm able to select audio track and subtitles provided in the MKV files.  :)

 

Are you sure it works streaming from a DLNA server like Plex? I just received last update (04.27.05) but this ain't changed. What is your software version?

 

I attach a detailed screenshot of my sw version  :)

Attached Files



#17 csiknor

csiknor

    Newbie

  • Members
  • Pip
  • 5 posts

Posted October 03, 2015 - 10:49 AM

Are you sure it works streaming from a DLNA server like Plex? I just received last update (04.27.05) but this ain't changed. What is your software version?

 

I attach a detailed screenshot of my sw version  :)

Yes, I'm using my NAS as the DLNA server. It used to be the case that I was unable to change audio tracks, although the TV could handle multiple audio tracks when I used the same file via USB instead of DLNA.

 

Please hav my software version as following:

https://dl.dropboxus...NA/IMG_3633.jpg

https://dl.dropboxus...NA/IMG_3634.jpg

 

This is an LG 42LB671V.



#18 benny.evangelista

benny.evangelista

    Newbie

  • Members
  • Pip
  • 3 posts

Posted October 04, 2015 - 10:34 AM

Yes, I'm using my NAS as the DLNA server. It used to be the case that I was unable to change audio tracks, although the TV could handle multiple audio tracks when I used the same file via USB instead of DLNA.

 

Please hav my software version as following:

https://dl.dropboxus...NA/IMG_3633.jpg

https://dl.dropboxus...NA/IMG_3634.jpg

 

This is an LG 42LB671V.

oh, your software version is 5 ... I don't know if my TV will get it...I hope so!

 

Thank you!



#19 Henrique Zacchi

Henrique Zacchi

    Newbie

  • Members
  • Pip
  • 1 posts

Posted December 30, 2015 - 03:33 PM

It's not immediately obvious but you CAN change the subtitles and audio track on Web OS 4.0.0.0. Here is how:

 

1) In Smartshare, choose a video and play it.

2) When Playing a video, click on the Additional Options icon. It's a left arrow Icon (<--) at the bottom right of the player.

3) Once you click the left arrow, it's clear. You can select the Subtitle option or Audio options. If the icons are disabled, it means it the video doesn't have addiitonal subtitles/audio.

 

That's it. I hope that helps.



#20 Yuriy

Yuriy

    Newbie

  • Members
  • Pip
  • 7 posts

Posted December 30, 2015 - 04:11 PM

Audio language selection become available about 2 months ago with firmware update. I have TV model of 2014 year.









0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users