Quantcast
Jump to content

  • 0

AirPlay "Unable to connect to".. 43NANO79


Kai Hendry

Question

6 answers to this question

Recommended Posts

  • 0

@Kai Hendry Make sure that the room where the TV is, has a good/strong WiFi signal.  Check what your smart phone is using (2.4GHz WiFi band, or the 5GHz band), and make sure that the TV is using the SAME BAND.  NOTE: do not confuse the WiFi 5GHz band with 5G phone capability, that just means "Fifth Generation"..... 😊

Also, check the WiFi strength "bars" icon, on the smart phone, in the same room as the TV to gauge its strength. If you have a laptop, it is much better to check the WiFi signal strength and quality with a nice utility from Nirsoft, called "WiFiInfoView". It is free, check here: 

link hidden, please login to view

Just download that, unzip it into its own folder, and run the .EXE executable from that new folder (you can right click and creat a shortcut to it on the desktop wallpaper, for later use).

By the way, if you can log into your router, go to the Settings, WiFi (both bands), and go to advanced, check the channels in use, try 36 or 44 for the 5GHz, or 8 for the 2.4GHz, AND ensure that the SSID names for both are not longer than 8 characters, and do not have any special characters in them (like BigAls'WiFi!~ or similar), as some LG TV sets do not like that.

Link to comment
Share on other sites

  • 0

@Kai Hendry Thanks for confirming that, I would NOT have known that fact until you posted it! What about "Check what your smart phone is using (2.4GHz WiFi band, or the 5GHz band), and make sure that the TV is using the SAME BAND."?? If the WiFi is strong, why did you choose to use a wired LAN cable, as that limits you to  100Mbps, and the 2.4GHz WiFi can be 150 - 300MBPS, with the 5GHz around  600 - 900Mbps or more  depending on your router model?  With the connectivity being intermittent, It might be worth disconnecting the TV LAN cable, and trying to see if connecting up the WiFi side stops the issue, BUT use the same band that the phone is using.

Link to comment
Share on other sites

  • 0

@Kai Hendry Before you take that drastic decision (that might not fix the issue), please consider this technical post I spotted on an Apple forum below, as I beleive that is DOES cover your error scenario, as I think the issue IS on the Airplay side, not the receivng (TV) side. Just because you get a good basic "connection" between the iPhone and the TV, does NOT mean that a complex APP protocol will fully function. Please read the quote below:

"The symptoms you describe are as if the multicast airplay discovery packets are being blocked. Some routers don't route these between wifi and ethernet, even on the same router. Other routers handle this and it's not an issue. You should never need bluetooth to make the AirPlay connection. The "Use AirPlay to wirelessly stream content from your iPhone, iPad, or iPod touch - Apple Support" Apple help document doesn't even mention ethernet, only wifi. When the ATV is wired, AirPlay from iPad may work intermittently, as you describe. It appears to "work", which is surprising, but then it just fails totally. Using bluetooth as you describe may get you past initial discovery, but there are still internal packets that expect to go direct over the wifi. I hope you can resolve at least some of these problems by switching the Apple TV [or the TV in your case] to wifi [from the current wired Etehernet LAN]." 

By the way, you might STILL need to check your WiFi SSID name, and see if the 2.4GHZ and 5GHz have DIFFERENT SSID names for each, or if they are merged into 1 name.  You will be fine if the 5GHz signal is strong and has a good signal quality, but can "flap" (disconnect/reconnect) between the bands if the name is merged, and the quality drops. Some complex apps can be sensitive to this.

"So I was having this same issue described in this thread and I believe I resolved the issue by making a change to my wireless network.

My wireless access controller (enterprise cisco network however same applies even for home routers) was advertising one SSID for both 2.4 & 5.1 GHz wireless networks. There is a feature in most new wireless access points called band steering. If you only create one SSID for your wireless network and it rides both your 2.4GHz and 5GHz network than your device will switch bands [flap] based on many factors including interference / congestion / signal strength. This explains the randomness of the connectivity as a microwave, or passing car, cell phone, or neighbour [on the same channel] can generate wireless interference very easily. The issue resides with the sending device however, because the issue was still happening on Apple TV's [and your TV scenario] that were not configured for wireless and actually plugged in via ethernet.

So my solution was to create a separate 2.4GHz and 5GHz wireless network SSID (wireless2.4 & wireless5.1 for example) and then configure my laptops and other APPLE devices on the network to only connect to the 5GHz network, and not allow them to switch based on the algorithm it uses to determine what the best connection is."

Link to comment
Share on other sites

  • 0

I think I found an issue with my Iphone DNS being set to Google DNS's 8.8.8.8. When I turned it to automatic, it appears to work more reliably.

 

Another element is to ensure Youtube is exited before trying to Airplay.

 

Nonetheless the whole "Smart TV" experience is a bit... underwhelming to say the least!

 

Thanks for your time.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By williemyers
      hi all,
      for a couple of years now, I've enjoyed AirPlay between my mid-2012 MacBook Pro and my LG Smart TV. But last week, I had to do a Migriation Asst./Time Machine re-install of the system drive on my MacBook Pro/Mojave. Result is that I can no longer get a connection with my LG TV. Two things:
      When attempting to AirPlay connect, I now get a Mac window asking for a PIN code. Then , the LG goes black and gives me a 4-digit AirPlay code, I enter it in to the Mac, but it reports, "could not connect to LG TV" etc. 2. I've put an AirPlay icon in the menu bar, but when I click on it, I see a greyed-out "AirPlay:" that constantly switches back and forth between "AirPlay: Looking for TV..." and "AirPlay: Off"
      All help/thoughts appreciated!
    • By Clifford Walker
      Upto a few weeks back had no issues but am unable to watch bbc weather page videos?
    • By DavidSr
      We have two LG TV's that stopped connecting to our PLEX media server after the last update. TImes out saying "Checking connection speed to Raspberrypi" which the PLEX is on
      Upgraded the Mesh Routers before trying anything, still only the PLEX app doesn't work
      Our other TCL TV and Roku and TIVO still work with Plex, so this is only the LG TV's that can't connect anymore.
      Another annoying error after the last update is that any Streaming app (Amazon, Netflix, and DIsney) now fall out of the app and go back to HDMI port 1 if we pause for 30 seconds.  Which we have always done for a Bathroom break or getting drinks.
    • By Dimmy
      All of a sudden I am unable to cast from my Windows 11 laptop to my OLED65CX TV. The only option given to me is to cancel the request. I've previous been able to cast without issues.
      Any fixes for this issue? Useless LG support agent told me to just use an HDMI cable and kept referring to the TV as a 'monitor'.

    • By JamesH
      I output the sound from my LG 75UJ657A to external speakers through a bluetooth connection, but it doesn't automatically connect to the bluetooth device when I turn the TV on. Whenever I cycle the TV off and, then, back on, the TV asks if I want to connect to the bluetooth device, and I have to select "yes" with the remote. My smart phone automatically connects to all the bluetooth devices I've set it up with. When I start my car, my phone connects automatically to the car stereo/phone system, and it does the same with other bluetooth speakers I have. This is what I want my TV to do.
      How do I get my LG 75UJ657A to automatically connect to the bluetooth device I've set up with it?
  • Similar Tagged Content

×
×
  • Create New...