Quantcast
Jump to content

New webOS 2.0 Firmware ver. 4.05.01


Recommended Posts

Hi everyone,

 

I made in this post a little firmware update tutorial. However if you don't have the knowledge to do this, ask for someone's help. I am not, in any way, responsible for any bricked devices.

 

So now, let's see the good news.

I just updated manually the firmware, cause OTA it was not available(although it apears on my country's website, but probably wasn't published on the update servers) and the first thing I've noticed is that the startup is even faster now. On previous version (4.01.00) upon turning on the TV and wanting to change the channel would take from 6-7 second up to 11-12. With 4.05.01, I can change the channel in 2-3 seconds. Also, the animations when moving through the menus seem to be a lot faster. Regarding if this is a lite version of webOS 3.0(e.g.: new menu icons, multiple user profiles, magic zoom, ), I think it is not, since I haven't noticed any new features compared to the old 4.01.00 version. I think this firmware brings only performance improvements. But we are on the right path.

So if anyone was wondering, in order to update the firmware from the USB memory stick, you need to follow next steps:

1. Connect USB Stick to PC or MAC and create a folder called "LG_DTV" on this USB stick

2. Download the update firmware from this link

link hidden, please login to view
. Insert your TV model and hit Search button. Download the latest version updated on the latest date(4.05.01 was published on 13.06.2016) and extract it on your desktop/download location. Now you will have a .epk file extension called "starfish-dvb-secured-m14tv-1.biscayne.m14tv-145-04.05.01-prodkey_usb_V3_SECURED".

3. Inside the LG_DTV folder copy the extracted file with .epk extension called "starfish-dvb-secured-m14tv-1.biscayne.m14tv-145-04.05.01-prodkey_usb_V3_SECURED" and then, safely remove the USB Stick from PC.

4. Connect the USB Stick to one of the TV's USB ports in the back and now SmartShare app will appear and also a notification to install the new Firmware.

5. Close the SmartShare app, and go to Install option. Now you have to wait...Read step 6

6. When the TV will have copied the Firmware from the USB stick, a message will appear on the upper right corner which will say that the new firmware will be installed upon rebooting the TV.

7. Shutdown the TV and hit the ON/OFF button on the remote again to turn it on, wait for the new firmware to be installed and configured. All your programs will remain in the order they were saved(so no need to configure again the channels) and also all the apps will be installed(no need to reinstall them).

That's it. Enjoy your new faster TV.

Link to comment
Share on other sites

The best update change is that the TV (I have a 55UF950V) now supports HDR!

It certainly works via the USB sockets at least.

Download some demo's (I suggest the Life Of Pi) and the TV will show the 'HDR Mode ON' banner at the top right

I don't have a UHD Blu ray player so cant confirm if it works through HDMI.

I've played a few Netflix and Amazon prime 4K  movies and shows and the banner hasn't shown up on those but they look ok anyway.

I've previously played some HDR demo's and they all looked washed out, now they look fantastic.

Link to comment
Share on other sites

I just found a problem regarding this firmware. If I have, let's say National Geographic on program number 17, sometimes when I open the tv, the program changes to a random number (today it jumped to 34, but at 34 I already had another program installed). And now I have program #17 free (no channel installed) and on position 34 I have two programs. This needs an immediate fix, cause it's one very annoying bug. I already reordered the programs 3 times, and this thing keeps happening.

Can anyone confirm this?

Link to comment
Share on other sites

  • 2 weeks later...

Older: "After a few days of testing, I come to the conclusion that Plex App for webOS was to blame. When I had it installed, well, you can read the previous comment of what it did. Now it's been 4 days since I uninstalled it and the bug didn't occured. That is why I came to this conclusion. I already bought XPlay, so I have no problem with Plex app being uninstalled."

 

I thought that Plex app was to blame the Program jumping from one number to another, but today it happened again. I don't know what the problem is exactly, but as I said in the 5th july post, this needs to be fixed as soon as possible.

Do someone from LG reads these posts? I am curious, cause I have my LG TV for almost 2 months, and discovered this forum since the first week with it. Hope LG have some people that read this, in order to know how to fix some of the problems their TVs have.

Link to comment
Share on other sites

  • 2 months later...
  • 11 months later...
  • 8 months later...

Can anyone confirm any change to the hateful wireless that this os has... I mean I could never attach any headphone (other than lg) to the TV? I have like 3 beautiful (and useless) headphones and I can't use them because the wireless search on my 49 inch lg tv never sees them... I just hate LG for that.... I'd never buy another LG tv... Any upgrade about that point... Any help????? 

  • Haha 1
Link to comment
Share on other sites

  • 2 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By Alfvenwave
      Hi, I'm curious if anyone else is seeing this annoying new behaviour.
      I have my SKY Q box on HDMI1 and have become accustomed to switching back from Netflix (or any other app for that matter) by having HDMI1 assigned to button "1" using the Quick Access feature.  In the last week though, this feature has stopped working properly. If I am in Netflix and I press the "1" button, nothing happens (as expected). If instead I hold down the "1" button to switch to SKY I get a pop up that says this: "Do you want to add Netflix to [Quick Access 1]?".   If I then hold down the "0" button, the 3x3 grid "EDIT QUICK ACCESS" pop-up appears and I can clearly see my SKY Q/HDMI 1 in the top left grid position (button "1")!!!
      If I then switch via the Home button to HDMI1 and remove HDMI1 from Quick Access (via the  EDIT QUICK ACCESS pop up), I can then re-add it by holding down 1 or from within the pop-up. Now, if I go into Netflix and then hold down 1, my TV does (correctly) switch to HDMI1. Hurrah! If however I turn my TV off and back on, then go to Netflix, then hold down "1", I am back to square one with the question "Do you want to add Netwflix to [Quick Access 1]?"......Grrrr!!!
      I have tried switching the TV off at the wall, leaving for 10 seconds and repowering, which doesn't fix the problem (I don't believe WebOS reboots when you do this). LG appear to have made it a practical impossibility to reboot WebOS via anything other than a factory reset which I don't really want to do as it'll take me too long to get all my settings back to where I have them now. Some blogs suggest that the "User Licence agreement" setting can be changed which forces a reset from within the General tab but I don't see this on my TV (guessing that WebOS interface has changed).
      Anyone have any ideas? 
      Rob.
       
    • By yenn22
      Hi, since I think yesterday I have an issue with HBO GO - it just shows unsupported device and that is it. According to their website, WebOS 3.5+ should be supported, I have LG uh6107 and in menu it shows SW version  5.60.15, so I think it should be ok.. does anybody have the same issue?
    • By Mohannad Hanafi
      I installed webOS TV Emulator v6.0.0 and when I run it, it shows a black screen like this
      It's running on Oracle VM VirtualBox.

    • By Justin Tan
      Found multiplex application that use letsencrypt stop working in 30 September 2021 on LG WebOS 3.5. This appear to be wide spread multiplex version of WEBOS. 
      See 
      AND 

      link hidden, please login to view As PLEX blaming to be LG fault. LG please provide solution to only 2 year old TV
      LG
      Our current app is available on 4K/UHD LG television models running the following system software:
      webOS 3.0 webOS 3.5 webOS 4.0 webOS 5.0 No 720p or 1080p (“full HD”) sets are supported for our current app at this time.
      Note: Due to root certificate limitations with the device OS itself, only webOS 5.0+ devices support secure connections with a personal Plex Media Server. To allow connections to a personal server, devices running earlier webOS versions must be set to Allow Insecure Connections in the TV app settings and the Plex Media Server must be set to Preferred for the Secure Connections preference.
    • By Vlatkovski
      Hello,
       
      After updating on 05.60.15 i have popping sound on all three hdmi ports.  I tried several different HDMI cables but it reappears when connected to the receiver. When I watch netflix or internet the sound is fine. 
      Is there a problem with the update or something is wrong with the TV? I repeat before the update the sound was great.
×
×
  • Create New...