Quantcast
Jump to content
  • 0

WebOS Arabic Subtitle problem


johnnylb

Question

the problem with WebOS Arabic Subtitle is that you have to change the encoding for each movie when you first play it not only that but also if the encoding is UNICODE the subtitle will not be understandable.

 

the mentioned problems didn't existed before in the older platform.

 

 

it is not accepted to have this "faux-pas" while all electronics manufacturers plan for improvements LG did a huge mistake using the WebOS.

the main purpose for buying a smart TV is to benefit from its internet access and movie playing and this is not achieved with LG WebOS TV.

 

i am not sure if this is the correct place to emphasize my problem... but i need solutions hope any LG Customer service support can contact me.

 

 

Link to comment
Share on other sites

  • Answers 5
  • Created
  • Last Reply

Top Posters For This Question

5 answers to this question

Recommended Posts

  • 0

I have find a solution for the encoding of the Subtitle via surfing net, i hope it may be helpful

It worked so good on my Lg 42LB6520 that Running WEBOS

 

I found a  hidden menu in WebOS which allows you to change the encoding, Size , Color and position of the subtitles of all languages.

 
First you have to save the subtitle file as Ansi Encoding by NotePad Program on any Pc
 
Steps:
 
1) Play your movie
2) When you see Strange characters appears with your subtitles hit Pause.
3) In the Pause menu click on the little arrow on the right hand side.
4) Click on the button that says 'Sub'
5) Click on External
6) A hidden menu will Appear!!!
7) Select Code Page that suit your languge till the Subtitle characters appeared fine
8) Also you can select Size, Color, Position, Sync....etc

 

 

Link to comment
Share on other sites

  • 0

I have similar problem with Farsi subtitle. Since the characters are same in both Farsi and Arabic subtitles, I think the reason of the problems is same.

When I watch a movie with Farsi subtitle (SRT file) the subtitle cannot be read even by changing the charset option in WebOS.

I saved the SRT file with UNICODE or UTF-8 encoding and when I watched it my PC it is OK, but in LG WebOS, it is not OK.

 

In fact the characters can be decoded correctly in WebOS but the problem is that Farsi and Arabic languages are written from right to left but the subtitle which is shown in LG WebOS is set from left to right. So the characters and words are messed and nothing can be read!!

 

If someone has any solutions or suggestions, I would appreciate.

Link to comment
Share on other sites

  • 0

hello to every one

I just bought the TV yesterday and when I just played a movie and select the code on arabic like every other devices , and saw that the srt is not showing farsi language I just become mad and angry giving 2000 dollars for a TV with out showing farsi sub ...

so I just changes all the codes without any hope and suddenly something strange happened ... the srt showed farsi language in Vietnamese code! I know its very stupid and silly but I just loved it because it worked!

I couldnt belive that but it worked very well so i came here to tell all of you people who want to play Srt in arabic and farsi use the vietnamese code it worked for me so i hope it work for you too...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By Filip_IT
      Hello
      I have login issue on a brand new LG TV 55UR640S0ZD there I  want to create content with content manager and create Groups with Group Manager 2.0.
      I´m trying to login to Dashboard with chrome and Internet Explorer browser which is connected to wlan with IP address:
      link hidden, please login to view  Here it says to Input Password and I have tested
      0000
      000000
      00000000
      1157
      admin
      Without success, what is the default password?  
      I have reset the TV from Hotell mode menu and ordinary Menu to factory default but does it exist any other way to reset TV?
      How can I get access to my TV?
      All help is appreciated
      BR. Filip


       
    • By Nitin Chopra
      Hi Team,
      After update of LG WebOS to 04.40.70, Amazon Prime Video app on my LG Smart TV stopped working. It started giving error :
      Internet Connectivity Problem
      There is an internet connection problem. Check the device's internet settings, data cables, or try to resetting your router. Also, turning your device off, and then back on might fix the problem. For further assistance, please contact Amazon customer service at www.amazon.com/videohelp
      The internet/wifi connection is fine and all the other apps are working without any issue on the LG smart TV.
      I have even tried uninstalling and reinstalling the Prime video app, but that didn't help.
      Has anyone faced this issue ? Is there a solution available for this issue.
      Thanks & Regards,
      Nitin
    • By bobjirous
      Hello,
      I am not able to force my new TV LG 49UN7400 to sound output only for BT - not BT headphones + internal speakers. Headphones are correctly paired, because "headphones + internal speakers" works, but I want hear sound ONLY in headphones and the choice "Bluetooth" is not active/selectable... 😕 Any suggestions? Thanks in advance.


    • By qUArtEx
      Hi to all! 
      I'm really new into this and have a problem. My 2018 LG 55UJ635V-ZF has only webOS 3 (latest; ethernet-automatic download) an i can't use airplay or miracast. The apps i found in the store for mirroring are only pay2use to use this needed feature for me.
      On the LG Homepage i can't find an upgrade for my TV an maybe is my tv really to old for upgrades or am i wrong?
      Maybe someone can help me out or bring some light for me in this.
      I also found the suggestions on this site for the firmware 4.70.70 (for the UJ's), but i can't download....error.
      sorry for my bad english 🙂
      thx for your help, quartex.
    • By GiotisCy
      Hello, 
      I have recently purchased an LG C2 Oled TV which I connected with my Samsung HW-Q800B 5.1 soundbar via eArc HDMI. When I select "Passthrough" as a Digital Sound Output on LG TV sound advanced settings, there is an obvious sound response delay around 3 seconds when I pause and unpause the movie on Netflix or Prime video streaming apps on LG TV. For example, when I start the movie, the video starts and sound starts 2-3 secs later. When I pause the movie, the sound continues for 2-3 secs after the video has been stopped. There is no any lip sync issue, just this response delay of the sound from the soundbar. This happens only on LG TV Apps. If I connect to an external HDMI device such as AMAZON Fire Stick 4K, there is no such sound delay issue neither on Netflix neither on Prime Video. 
      Thus, the problem seems to be on LG TV apps.
      If I change the Digital Sound Output to "Auto" instead of "Passthrough" the issue is gone but sound quality is not as good as with Passthrough selected. So I do not want this to be my option.
      I would appreciate if someone could come with a solution on this. 
       



×
×
  • Create New...