Jump to content
  • 1

LG Store not working



Tv is connected to internet but when I run LG Store it won't open. After a while it shows network error (4). It was working few days ago, but it simply stopped. Firmware is latest and i'm not sure if it updated automatically but on the lg site firmware date is about when this problem occurred. Tv model is 42LB671v and firmware version is 40.30.16. Is there any way to downgrade to previous version or any other solution? Thanks

Link to comment
Share on other sites

Recommended Posts

  • 0

I'm having the same problem, I only just bought my TV yesterday so was panicking I had a shoddy model. I was able to update to the latest firmware this morning, though pretty much as soon as it updated I can't use any apps or check for new software updates. I should note, that on the Network tab it says 'connected to the internet' which is false, as I get Network Error(4) for everything.


Have called support, they're over-run and claim will call me back. Hopefully this gets resolved soon, as I was so excited to start using my new TV :(


Please let me know if you guys hear anything.

Link to comment
Share on other sites

  • 0

Have to same problem on my 55UB850V after firmware upgrade yesterday to 04.30.18: Network error(4) on the LG store

But the web browser is working perfectly

This is so annoying: i can't even watch Netflix, because the app wants to connect to the LG store

Will LG refund me for these days I can't watch Netflix?

Link to comment
Share on other sites

  • 0

TV 47LB6520 webos smart 3d

same issue from yesterday evening. cannot open any net content other than web browser. i did resetting to initial settings. but still the same issue. says network error (4). 


Did anyone find any solution. just brought this TV a week before. It was so annoying as this happened so soon for me as me and my friend brought the TV on same day. I brought LG and he took samsung 48inch 6400 and it works like charm with  all connectivity with flash plugins related apps and sites and a lot of apps than LG in middle east region. while LG webos does not support flash and have very less useful applications. may be with in 10.


Please update if any solution is there for LG store app.

Link to comment
Share on other sites

  • 0

I am having the same issue.


i bought the tv 5 days ago, i had this issue with the lg store not opening, i upgraded the fw the other day and still have the same issue.

(with the new firmware i also got the netflix app, which as well is not opening)


country set to germany, tv  55lb640v za 


If someone have more info about this pls let me know.

Link to comment
Share on other sites

  • 0

Same problem here.


32LB650V-ZN, Denmark.


Been like that for some time. Maybe it started with firmware 04.30.16?


Also "Account Management" in settings doesn't work. If available from the "Quick settings" pane (sometimes it is available here, sometimes it's not?) it just hangs at a black screen if I try opening it. If I try opening "Account Management" from the "General" pane, I'm just immediately thrown completely out of settings.

Link to comment
Share on other sites

  • 0

mine seems to work as well; still i found it a very negative experience. Apps like 'Netflix' shoudn't be affected because the 'LG store' is not working properly.

An outage like this and you can take the 'smart' out of your smart-TV.

This will definitely influence my decisions when purchasing a new TV in the future (and not in a positive way).

Link to comment
Share on other sites

  • 0

I just bought a LG730V-ZD TV. Firmware version: 04.30.16 webostv version:1.30.0-3216 I'm from Macedonia

The problem is that i can't use any of the apps on the TV other than the web browser. I cant enter the LG Store app. And i get this network error 4.

This is very frustrating as I bought the TV 2 days ago.

Anybody have solution to the problem?

Link to comment
Share on other sites

  • 0
I have the LG55UB850V. A couple of days ago, I started to get intermittment problems accessing the LG store. Sometimes I can connect and sometimes I can't. Also, when I do manage to start viewing content on Netflix, after about 1 to 2 minutes of play, Netflix just crashes. I restart Netflix then in about 1 to 2 minutes the same thing happens. This is VERY frustrating. The problem is certainly not my internet connection as I can watch BBc iPlayer just fine and have recently started using the new Spotify app. So is the problem the Netflix app, the LG Web OS operating system or the LG store or a combination of these. Has LG commented on these issues.


Any advise would be appreciated.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By ct3fq
      Hi List,
      Is it possible to run a script on power on TV? i.e.  We want that TV  stays in a site browser on power on.
      Any help would be appreciated
    • By João Inácio
      After a software update earlier this year (2022), the LG OLED55C1 TV web browser no longer correctly measures my internet speed. Before average normally. However, I believe the TV uses my Internet speed to the full because I can watch 4KHDR Streaming without any problem (Netflix, Prime Video). It's just the measurement in the web browser that shows grossly wrong results - My Internet contracted is 500Mbps and my TV's web browser measures 25Mbps (speedtest.net). The browser only measures the download speed wrong, the upload speed it measures right, as well as latency and ping.
      Several times I tried to report this problem to the local LG (Brazil), but they do not recognize the software error and only respond with irrelevant and useless information. There are several reports of this problem posted on the Internet, and even then, LG ignores the problem.
      Does anyone know how to contact the software development team at LG? I think they stay in Korea.
    • By majorusa
      Please post here firmware number for your WebOS set including your country or the country where you downloaded the firmware and the model of your tv set:
      - 3.23.24 - Romania- 47LB730v
      - 3.23.34 - Romania -47LB730v - 21.08.2014 by USB
      - 4.30.09 - Romania - 47LB730v - 29.08.2014 - OTA
    • By Enx_xcite
      How Can i do for Unlock MY LG 43UP7750PSB.APH to PTB.ATM coz i moved to thailand DVB-T2 not working

      Anyone has any ideas? or Solutions?
    • By Mike F
      Apologies for what might be a newbie question.  I have a 55" Nanocell 80 series TV.  I've used it for, among other things, casting FloSports from my iPhone.    This always worked well and was much more stable than Roku, which kept throwing me out of the app.  I go into the FloSports app on my phone, it prompts me for the casting output, I choose [LG] webOS TV NANO80UPA.  Until now, it has always worked.
      Last night, out of nowhere, I got an Error Code -201.  I looked it up:  Unable to Load, Server Certificate has expired or is not yet valid as the set time on TV is different from the current time.  Please check time settings.  I checked.  Time settings are correct.  It was suggested that my Internet speed may be lacking, but other apps like YouTube work just fine.  Another tip was to ensure I had the most current software patch.  Apparently, I do (03.33.11.)  Googling it suggests that this is a YouTube error but, again, YouTube is OK.  AirPlay is not.
      Any ideas?  Thanks in advance!
  • Create New...