Jump to content

[pivotCE]Bing Maps Patched for webOS


Recommended Posts


Bing Maps has been patched for their latest API change for webOS.  webOS Nation forums user, Misj’, has developed two patches to cover both the Pre and TouchPad bases.

Microsoft has switched over to v8 of the maps API and left our old v7 in the dust. Misj’ discovered the issue and wrote a simple patch to change the URL the app points to.

link hidden, please login to view
Before and after on a Pre.

It’s not 100% perfect since this change doesn’t fix a couple things:
– Birds-eye view does not work any more and results in a blank screen.
– Even though the locale is set to PalmSystem.locale, you may have to add your country to your search criteria to make sure you don’t get a random country result.

Before and after on a TouchPad.

There’s also a little bit of confusion about which patch to use since some have reported that the TouchPad version of the patch doesn’t work on all TouchPads.  For some reason, some TouchPads have the Pre version of Bing Maps or so it would seem. Basically, if you try to install the TouchPad patch and it fails, try the Pre3 version and you should be fine.

You can get the patches and talk about it .

Personally I use Google Maps by 72ka which generally speaking works perfectly. But I’m always happy when a developer takes the time to restore functionality to webOS. Thanks Misj’!



Related posts:

Link to comment
Share on other sites

  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Popular Days

  • Similar Topics

    • By Lgrump
      Is it just me or is the plex app just unusable on webos.  When I try to select dvr items with the magic remote they just don’t play.  I am not sure if this is a plex issue or an lg webos issue.  Anyone know which it is?
    • By Frederik Kordiak
      Hi all, so I have 2 LG OLED TVs at home and I am connecting them to 5GHZ Wi-Fi, no problem until yesterday. Suddenly, I am not able to use the apps (Netflix, IPTV, Disney etc.) and both TVs are showing connection issues. The same Wi-Fi works on my PC and mobile though. So I tried connecting using a different Wi-Fi with my hotspot and both TVs worked again with no problems. I tried restarting my router many times and my provider said there is no issue on their end, but I am not able to use the home Wi-Fi anymore. 
      Have you seen this before? Is it possible that my provider blocked my LGTVs from accessing their network?
    • By Blessing Antro
      When I cast my device on Amazon Prime through my smartphone the lg tv was not found through searching from my mobile, It was working only in screencast... So kindly pay attention to this and sort out all the problems thank you
    • By Superjack747
      I’ve submitted my app in October of last year, it has been reviewed only twice, for issues of LG testing systems I’ve been requested to resubmit the app and every time weeks of waiting.
      Is anybody else having similar issues?
    • By Sylvie G
      When I try to watch replay or live TV from Belgian casts in the browser I have error messages:
      - for Auvio (RTBF) it is purely incompatible
      - for RTLPlay , the message says that the browser version is too old and has to be updated.
      It is impossible to install alternative browser on LG smart TV, or to update the LG one.
      WebOS is not really a good idea, or at least it should be more "open" for the apps that are not proposed or updated.
      I know it is possible to share from other machines (tablet, phone or computer) but I want to use my TV "alone" too!
      Do you have a solution (other then buying a chromecast or equivalent device?)
      Thank you

  • Create New...