Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    Register now to gain access to our webOS user support forum. Once registered and logged in, you will be able to post a user to user support request topic to this site or reply to existing topics posted by other users. You can also take part in our other webOS user forums. You'll be able to customize your profile, receive reputation points, while also communicating with other members via your own private inbox, plus much more!

  • 0
Sign in to follow this  
Jeff Tyson

Can't install Emulator v2 or v3 using Component Manager

Question

I have installed the SDK, and I'm trying to install the v2 and v3 emulator using the component manager.  When I click install it says Downloading but is stuck at 0% eventually it errors out saying "Network connectivity issues. Try again after some time.".  I have tried uninstalling and re-installing the SDK, rebooting my computer and using a different network.  Nothing seems to work, it keeps failing to download.

Please help.

--Jeff

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts



  • 0

I found workaround for this issue.  

  1. Run componentmanager from webOS_TV_SDK\ComponentManager
  2. Click download for the emulator version which you need. And after "downloading" text will appear cancel it
  3. Go to TV_logs subfolder and find there latest log file. In the end of this file you will find URL like this https://developer.lge.com/resource/tv/RetrieveToolDownloadUrl.dev?fileId=RF00013183 (may be it different for different OSes)
  4. Now open url in this browser and you will see there something like this 
    {"fileId":"RF00013183","gftsUrl":"https://gfts.lge.com/fts/gftsFilePathDownload.lge?key=dlRF00013183&hash=63VaDyhP7SS5WkQP&mtime=1553668504000"}
  5. Copy generated URL and download emulator zip file
  6. Unzip downloaded file to webOS_TV_SDK\Emulator directory
  7. Now you can create shortcut for the new emulator. Just copy and modify shortcut for v.4.0.0 created by installer. Don't forget to modify working directory too.  Right machine id you can find in LG_webOS_TV_Emulator.bat
  8. If you installing web os SDK first time  you need to register emulator using vm_register.bat
  9. That's all folks! (c)

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • Question: Issues with Pioneer Receiver

      I have a LG webOS TV UJ6300 and Pioneer VSX-S520 both purchased in the US. Used these together for a year in Turkey with no issues, just moved to the UK and I can't get audio from my TV to play through my receiver. TV software is up to date, SIMPLINK HDMI-CEC is on, set to HDMI/ARC. Receiver firmware is up to date and confirmed HDMI cable is plugged into the ARC on both. I have tried multiple audio settings, multiple locations in tv settings, changing them and then setting them back, d

      in LG webOS Smart TV Questions

    • LG UH7700 Video Issues

      Hello, I have an issue with a 2 year old LG UH7700 4K tv. Please note, the TV went to an authorized LG repair  shop provided by LG itself: Issue: 3/4 of the screen all of the sudden was not working. It went to black opacity and full black.   This first occurred one morning when I first started tv. Called LG and it was over the warrant by a year so they provided with a certified tv repair technician. They replaced the LED bulbs and tested by keeping it in for 8 hours while viewing

      in LG webOS Smart TV Discussion

    • Apple TV 4K Issues with LG UJ7700 WebOS 3.5

      I'm not sure if this is an LG or Apple issue, or if I have to try a different HDMI cable (the package says it's the latest standard) but here's what I've seen so far: I have the AppleTV 4k using Dolby Vision which looks great. 1. When using the AppleTV remote to turn on the AppleTV and LG TV (using LG Simplink), sometimes the video signal is messed up – it's blurry and out of sync. Changing the input to Live TV and then back to the AppleTV fixes it. Sometimes it just works right away.

      in LG webOS Smart TV Discussion

    • Question: Help! TV Stuck on Netflix Screen

      It is stuck on the Netflix screen. The remote does not work, only the power button works. How do I reset the TV? 2017 OLED model

      in LG webOS Smart TV Questions

    • Question: Subtitles issues

      Hi... I am Anand Mishra from Mumbai in India. I recently bought C8 Oled 55 inch TV. Everything is fine with it, except one issue i am facing. Whenever, I watch movies through External HDD, subtitles not poping up on the screen.  Even, I checked it in setting and turned it on. Still problem persists. Pls help. 

      in LG webOS Smart TV Questions



×
×
  • Create New...