Quantcast
Jump to content



  • Own an LG TV or webOS device? Join our Forum!

    Register now to gain access to our webOS user support forum. Once registered and logged in, you will be able to post a user to user support request topic to this site or reply to existing topics posted by other users. You can also take part in our other webOS user forums. You'll be able to customize your profile, receive reputation points, while also communicating with other members via your own private inbox, plus much more!

  • 0
Sign in to follow this  
Jeff Tyson

Can't install Emulator v2 or v3 using Component Manager

Question

I have installed the SDK, and I'm trying to install the v2 and v3 emulator using the component manager.  When I click install it says Downloading but is stuck at 0% eventually it errors out saying "Network connectivity issues. Try again after some time.".  I have tried uninstalling and re-installing the SDK, rebooting my computer and using a different network.  Nothing seems to work, it keeps failing to download.

Please help.

--Jeff

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts



  • 0

I found workaround for this issue.  

  1. Run componentmanager from webOS_TV_SDK\ComponentManager
  2. Click download for the emulator version which you need. And after "downloading" text will appear cancel it
  3. Go to TV_logs subfolder and find there latest log file. In the end of this file you will find URL like this 
    link hidden, please login to view
     (may be it different for different OSes)
  4. Now open url in this browser and you will see there something like this 
    {"fileId":"RF00013183","gftsUrl":"https://gfts.lge.com/fts/gftsFilePathDownload.lge?key=dlRF00013183&hash=63VaDyhP7SS5WkQP&mtime=1553668504000"}
  5. Copy generated URL and download emulator zip file
  6. Unzip downloaded file to webOS_TV_SDK\Emulator directory
  7. Now you can create shortcut for the new emulator. Just copy and modify shortcut for v.4.0.0 created by installer. Don't forget to modify working directory too.  Right machine id you can find in LG_webOS_TV_Emulator.bat
  8. If you installing web os SDK first time  you need to register emulator using vm_register.bat
  9. That's all folks! (c)

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Topics

    • By Noel Walker
      When trying to load the Plex app on an LGWebOs smart TV, app says :-
      CHECK NETWORK CONNECTION    Error CODE : -337
      This may be a temporary issue. 
      Please try again later. 
      (RETRY)     (EXIT APP)
       
      Firstly my network connection is fine. Netflix and YouTube loads and runs just seamlessly. This has only been happening in the last few months If I (RETRY) after a long wait sometimes it connects and loads correctly or I get the same error again. I have tried other Plex clients on my home server and they work just fine.  Specs:
      LG OLED65C8PTA TV running Web OS 04.10.15. LG Plex client app is version 2.1.6 from Sep 2016 Plex server is on my QNAP NAS and at version 1.13.5.291 from Sep 2018. I guess my question is, if the LG Plex client app hasn't changed since 2016 and my Plex server is working for other clients, then what is going wrong?
      Cheers
      Noel
       

    • By harika dasyam
      Iam using  web os 5.31.0 version but iam unavalibile to see hot star please conform me the is it support or not

    • By Akash Akash
      i want to download jpeg picture from my lg tv browser and  when i click on download  it says file not support ed
    • By Amir Abulajras
      Hey guys i live in spain and i have the  lg 43UK6300PLB smart tv.... the problem is my connectivity speed i have 600mbps download and upload at home but the problem is wheni go to smart tv web and go to fast.com or go to speed .net i only get 90mbps max i tried wired and i tried wifi ... and the ping on the tv gets up to 140 to 200 i mean why i checked everything reset everything and i still get that amount as max and when i do the test run on my laptop i get the full 600mbps!!! i am just mad as i couldnt figure it out... i tried all online solutions but nothin!! please help
    • By TMOSteel
      If anyone is still experiencing issues with the webOS Disney+ app (and I suspect many if not all of us still are) such as the lack of 4K support, 5.1 audio support, or as in my case with the 86UH9500, both, please see LG's response to my inquiry into these issues:
      We appreciate you for patiently coordinating with us regarding the current application status of your LG 86UH9500 TV, Xxxxxxx. It is our goal to ensure that you are able to utilize your LG product at its fullest potential so let us assist you with your inquiry today.

      In response to this, according to the specifications of the unit, the LG 86UH9500 TV has been designed with a 4K UHD and Surround Mode feature. However, if the Disney+ app is the only application that does not output surround sound, please be advised that both the content being played on the TV and the applications should also support this feature as well. This case on the capability and support made by the developers of the Disney+ Application needs to be raised directly to them so that they can make the necessary updates on the programming and utilize our TV’s 4K UHD and Surround Sound features that are already available in our OLED Television. You can reach Disney+ Support Line at 1-888-905-7888 for additional support and assistance.
      So, as expected, LG is pointing the finger at Disney to resolve these issues.  This makes sense as my inquires into the availability of the Disney+ app from LG before the launch directed me to reach out to Disney+ as they, not LG, are responsible for it. 
      So if any of you out there have Bob Iger on speed dial, can you give him a ring?
      Thanks!
      (PS yes, LG incorrectly identified the UH9500 as an OLED model when its an LCD, but I'll let it slide)
       
       
       


×
×
  • Create New...