Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    Register now to gain access to our webOS user support forum. Once registered and logged in, you will be able to post a user to user support request topic to this site or reply to existing topics posted by other users. You can also take part in our other webOS user forums. You'll be able to customize your profile, receive reputation points, while also communicating with other members via your own private inbox, plus much more!

uKER

Unable to send multichannel PCM audio from PC to LG B6

Recommended Posts

I recently purchased a B6, and came to realize my good old AVR (a Denon 1612), featuring HDMI 1.4, won't do HDR pass-through, so intending to keep the Denon, I switched to having the TV in the middle, instead of the AVR as I did until today.  I have managed to get audio sent from the TV to the AVR via both ARC and optical, multichannel working fine, but the problem came when I tried to have multichannel audio from the PC to the TV.

The problem is, the PC (using a GeForce 1070) sees the TV as accepting only stereo PCM audio, and only allows to select stereo in the device's speaker setup. Needless to say, I need 5.1 PCM to get multichannel audio in PC games.

I even tried using an EDID override, copying the audio capabilities from the Denon to the TV, which allowed me to have Windows think it can send the TV any of the stuff the Denon takes, but even then any audio from channels other than left front and right front  is lost along the way to the AVR. My guess is that for whatever reason, the TV is decoding the stream and only letting L and R through.

On the bright side of things, multichannel pass-through does works fine for DD and DTS streams, allowing to watch a movie on the PC and have semi-decent multichannel on the AVR. Dolby TrueHD and DTS HD, though, are a no go, even using ARC (optical obviously doesn't support HD audio).

So yeah... Any ideas? Suggestions?

I'd like to think I won't be forced to buy a new AVR just to have it pass through HDR, so any help will be appreciated.

 

Share this post


Link to post
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Forum Topics

    • Question: Moving from the Middle East to New Zealand

      Hello there, I am struggling at the moment with our brand new smart tv which we took brand new and never opened with us when we shifted from Dubai to New Zealand. I can't get to the content store to download netflix, I only see Premium with 4 options (amazon, al jazeera and 2 orhers). I tried changing the location on the settings but I can only chose from the Middle East and Africa and when I try I get no change whatsoever to the options on premium. This is highly frustrating as we moved to a new house and were hoping to watch tv straight away, specially with kids. Any help would be truly appreciated.

      By Alba, in LG webOS Smart TV Questions

      • Awaiting best answer
      • 0 votes
      • 1 answer
    • Question: 5.1 passthrough issue

      Hi, I have a setup:  * TV: LG webOS 65UH950V * Receiver: Denon AVR-X2000 * Set-top box: Intek HD-C63CX  (5.1 capable)   In the case if cable set-top box is previousli set to channel with 5.1 sound (CH 5.1) and TV will be switched on, everything working fine, sound is 5.1 from receiver (Denon lcd panel shows "Dolby D"). If changing channel from set-top box to one with stereo audio, it's working fine too, receiver is playing stereo (Denon is showing "PLII C"). If changing channel from set-top box back to CH 5.1, there is no sound anymore. Denon lcd panel shows "PLII C". And sound is coming back only after restarting TV (standby and back on). After restarting TV, text on denon panel will change to "Dolby D" again too. All devices are connected by HDMI, receiver in HDMI 2 ARC. Software is newest (04.30.65), at least Check for updates didnm't find anything newer.   It is very disturbing as browsing channels almost always resulting loosing sound, because some channels are with stereo sound and some are 5.1. Pretty tired of restarting TV all the time, it's probably not meant to be so.    

      By bonzo, in LG webOS Smart TV Questions

      • Awaiting best answer
      • 0 votes
      • 0 answers
    • Question: Service Menu to Enable Dolby Digital passthrough

      Found several threads online that mention two things to change under the service menu. One is EDID from PCM to AC3 and I have. They said you need to write the change to all HDMI ports, how?

      By Nicholas Smith, in LG webOS Smart TV Questions

      • Awaiting best answer
      • 0 votes
      • 0 answers
    • How to Upgrade to web2.0 in Oman (Middle east)

      Please tell me the steps to upgrade to web2.0. I have seen news of updates being available,  

      By Jitendra Pandey, in LG webOS Smart TV Discussion

      • 3 replies
      • 1,296 views
    • Today app configuration

      Today app should have some kind of configuration, where you can choose which video apps suggestions appear.
      Like, only netflix suggestions, netflix and hulu, and so on...

      Sorry about my poor English.

      By Ian Augusto Jacques Harbs, in LG webOS Wish List

        
      • 2 replies
      • 2,344 views
  • Similar Tagged Content

    • By emmanuelbeziat
      Hi everyone,
      It seems that the Window command "Read on device" don't work properly with My LG UH661V.
      The problem:
      Once the video start, it will just stop and get back to main menu after a minute or so. If I try to change the video timeline, it stops immediately. But it seems to only happen if the file content isn't longer than ~30 minutes. Minor issues:
      With AVI files and MKV files, the timeline just don't work. Trying to change the time just result in an error message on the TV. Other points:
      The WebOS is up to date. Windows OS is Windows 10, up to date too. Tried to read on Xbox One and a Samsung TV, and it works just fine. Only happen with LG TV. Any thoughts on this?
      Thanks !


    • By Tilo
      Hi,
      i have a Pioneer 5.1 receiver connected via HDMI-ARC.  Sound by watching live-TV is ok, Dolby Digital output too.
      Watching Netflix or Amazon Dolby Digital output is not working and gets very heavy sound failures. Sound's working only in PCM! That's very poor.....
       
      My settings:
      Audio output via arc "automatic"
      DTV-audio settings "automatic"
      firmware 04.70.45
       
       
      Any solutions??
    • By Ricardas
      Hello, I have been enjoying my OLED B6 WebOS 3.0 model for half year. Just out of the sudden my two Windows machines with LG SmartShare app cannot discover my TV anymore. So I can still stream movies if I go to my TV Photos and Videos app and it detects my computer media service(s), so I can select desired video and watch it. However I cannot start streaming from my two Windows 10 computers - each computer detects another one, however TV is not detected, I cannot right click on video file in SmartShare app and find TV set under "Play to" menu.
      My TV and main PC have wired connection with my router, another Windows machine is laptop with WIFI only. I have tried to disable/enable TV's wired and wifi internet settings... no luck ;-/

      Any hints?..
    • By MAUICUDA
      Great picture but how to fix lip sync problem, only on ABC network channels, coming from Spectrum Hawaii?  Same cable box into my older Panasonic Plasma, using same HDMI cable: do NOT see lip sync problem.  What am I missing, or what is different coming in on the cable that bothers the LG set but does not   bother the Panasonic TV?


×