Quantcast
Jump to content

  • Join Today, It's Simple and FREE!

    Register now to gain access to our webOS user support forum. Once registered and logged in, you will be able to post a user to user support request topic to this site or reply to existing topics posted by other users. You can also take part in our other webOS user forums. You'll be able to customize your profile, receive reputation points, while also communicating with other members via your own private inbox, plus much more!

G.A.

Smartshare audio track change problem

Recommended Posts

How to change audio language?

I Was watching a film. (Mkv)

I stopped playback.

Tv said there is firmware update. I updated to firmware 04.30.09.

Later i wanted to continue the film, but the audio language changed to english. I can not switch It back to to original. The audio icon in the menu is inactive (like It was always).

Im playing the film through Dlna from my NAS.

Any ideas, how to Change language?

Share this post


Link to post
Share on other sites


I have the same problem after update.

I can't switch language from english when playing mkv over DLNA from my PC HDD.

It can be fixed if I delete all audio except required languge from mkv file.

I think that is new firmware bug.

Share this post


Link to post
Share on other sites

I have the same issue. The local support told me unfortunately the DLNA client does not support switching audio streams. However, watching the same MKV from USB works fine, I can switch between audio streams.

 

Hopefully they'll solve this problem in the DLNA client because I don't want to remove additional audio streams from each and every MKV I have.

  • Like 1

Share this post


Link to post
Share on other sites

I have the same issue. The local support told me unfortunately the DLNA client does not support switching audio streams. However, watching the same MKV from USB works fine, I can switch between audio streams.

 

Hopefully they'll solve this problem in the DLNA client because I don't want to remove additional audio streams from each and every MKV I have.

Ok, no changing Tracks on DLNA, but I checked the MKV file with MKVMerge.

My wanted audio track was the first, it had the same language whitch is set default on TV, and it was the default audio Track in MKV.

So it seems WebOS picks audio track randomly. (or it always picks the English Track...)

I hope it will change soon.

Share this post


Link to post
Share on other sites

Ok, no changing Tracks on DLNA, but I checked the MKV file with MKVMerge.

My wanted audio track was the first, it had the same language whitch is set default on TV, and it was the default audio Track in MKV.

So it seems WebOS picks audio track randomly. (or it always picks the English Track...)

I hope it will change soon.

 

It's closer to random. Mostly it chooses English but there are cases when other streams come out as winners. FYI, I've created a shell script to easily create a copy of an MKV file with the video and one audio stream. It's on GitHub: https://gist.github.com/csiknor/ad9d9db0f0f2cb9767a6

Share this post


Link to post
Share on other sites


Local languge came back as default with new firmware update for mkv in DLNA client. Howewer audio languges switch does not work.

So only one local audio track from mkv file is avalable to play.

Share this post


Link to post
Share on other sites

Local languge came back as default with new firmware update for mkv in DLNA client. Howewer audio languges switch does not work.

So only one local audio track from mkv file is avalable to play.

 

I have updated to the latest firmware but the issue is still there. I have an MKV with multiple audio tracks and the playback starts with the english one not the local language (the language settings are set to define hungarian as the local language).

Share this post


Link to post
Share on other sites

I have local language plaing with my mkv files now. Not sure how DLNA client select tracks to play but each mkv file has adio "track#" and "default" property for each audio track.

My files have local languge as track #1 and its "default " property = yes.

Share this post


Link to post
Share on other sites


Hi! I started having this annoying issue on my 42" 42LA740S after an update, probably the same as you. Out of the box it was possibile to switch language and subtitles while streaming (I use Plex as media server on my PC). I'm trying to get an answer from the LG italian support, but I expect nothing  :unsure:

 

I think they removed this functionality from the DLNA player for some reason, and they are never putting it back  :huh: 

Maybe if we flood the support with emails.... :D

edit: I found this article explaining how to downgrade TV firmware 

http://blog.techflaws.org/2014/05/26/firmware-downgrade-for-lg-smart-tvs/

 

I'm not new to this kind of thing, but I think is a little dangerous because there is no "recovery mode" or a way to flash the firmware directly from a pendrive USB, but you need to trick the TV to make it download a specific version of the software from your PC instead of LG official website.

Share this post


Link to post
Share on other sites


 

Actually, with the latest software update the whole issue has has been resolved for me. I'm able to select audio track and subtitles provided in the MKV files.  :)

 

Are you sure it works streaming from a DLNA server like Plex? I just received last update (04.27.05) but this ain't changed. What is your software version?

 

I attach a detailed screenshot of my sw version  :)

post-5215-0-88151800-1443873758_thumb.jpg

Share this post


Link to post
Share on other sites

Are you sure it works streaming from a DLNA server like Plex? I just received last update (04.27.05) but this ain't changed. What is your software version?

 

I attach a detailed screenshot of my sw version  :)

Yes, I'm using my NAS as the DLNA server. It used to be the case that I was unable to change audio tracks, although the TV could handle multiple audio tracks when I used the same file via USB instead of DLNA.

 

Please hav my software version as following:

https://dl.dropboxusercontent.com/u/430331/LG%20webOS%20DLNA/IMG_3633.jpg

https://dl.dropboxusercontent.com/u/430331/LG%20webOS%20DLNA/IMG_3634.jpg

 

This is an LG 42LB671V.

Share this post


Link to post
Share on other sites

Yes, I'm using my NAS as the DLNA server. It used to be the case that I was unable to change audio tracks, although the TV could handle multiple audio tracks when I used the same file via USB instead of DLNA.

 

Please hav my software version as following:

https://dl.dropboxusercontent.com/u/430331/LG%20webOS%20DLNA/IMG_3633.jpg

https://dl.dropboxusercontent.com/u/430331/LG%20webOS%20DLNA/IMG_3634.jpg

 

This is an LG 42LB671V.

oh, your software version is 5 ... I don't know if my TV will get it...I hope so!

 

Thank you!

Share this post


Link to post
Share on other sites

It's not immediately obvious but you CAN change the subtitles and audio track on Web OS 4.0.0.0. Here is how:

 

1) In Smartshare, choose a video and play it.

2) When Playing a video, click on the Additional Options icon. It's a left arrow Icon (<--) at the bottom right of the player.

3) Once you click the left arrow, it's clear. You can select the Subtitle option or Audio options. If the icons are disabled, it means it the video doesn't have addiitonal subtitles/audio.

 

That's it. I hope that helps.

Share this post


Link to post
Share on other sites


Hello everyone. I am having the same issue as everyone. Change language track is disabled in the menu. I am pretty sure I was able to do that a couple of months ago. Probably I updated the firmware. The TV is a LG 32LB580B-SA-SA_37. Firmware is 04.02.06 and Tv says there is no update available

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Topics

  • Similar Tagged Content

    • By prakhar_singh
      Updated my LG 55UK6360PTE to version 05.10.10 a few weeks ago. Few days after the update the television has trouble booting up, it gets stuck on the lg logo, then I have to switch the tv off by holding the power logo for a few seconds, then boot it up again only to find it getting stuck on the lg logo again, after repeating this process a few times I am finally able to boot the tv and proceed smoothly until I dare turn it off to face the whole issue all over again. Anyone else witnessed the same problems, is there anyway to downgrade the webos, tried the lgdtvupdater but it doesn't work, I guess it only works for models upto 2017. Correct me if I am wrong
    • By Schneider
      Hello everyone!
      I've just bought the new LG 55SM8600PLA with the latest update (AirPlay 2 and HomeKit support) and having many problems with it.
      The moment I plug the Ethernet cable on it, the TV starts spamming my entire network with Zeroconfi packages (captured with WireShark) resulting on all devices becoming unresponsive and slow.
      Here is screenshot of me pinging a wireless device with latency higher than 500ms, the moment I turn off the TV, ping goes to normal ~1ms (all cable):

      This happens with all devices on my local network. Using a couple of Asus RT-AC68U routers.
      Does this happens to any of you?
      Thanks!
    • By Gursewak Singh
      When will we get sony liv app in our lg smart tv. Please update the true status.  We all are eagerly waiting for sony liv app.
    • By Rohit Gupta
      I want to ask that what is the ideal total power on time for a new lg tv. I bought one and it already shows 1048 hours. Is this possible for a new tv? Anyone have any idea?


×
×
  • Create New...